I can't import files in .txlf format
Շարքի հրապարակողը: Zeki Güler

Zeki Güler  Identity Verified
Թուրքիա
Local time: 09:49
Անդամ (2012)
անգլերենից թուրքերեն
+ ...
Jan 27, 2019

Hi guys,

I received a project form my client in ".txlf" format and was told that to get the new files to work, I need to add "*.txlf;" to the beginning of the list of wildcard file extension types I have under "XLIFF" in my File Settings/Project Template.

Now, I even cannot import the files with .txlf extension into Memoq, as Memoq cannot see those files although there in my folder.

I tried adding it in "Filter configurations" but it doesn't work, probably
... See more
Hi guys,

I received a project form my client in ".txlf" format and was told that to get the new files to work, I need to add "*.txlf;" to the beginning of the list of wildcard file extension types I have under "XLIFF" in my File Settings/Project Template.

Now, I even cannot import the files with .txlf extension into Memoq, as Memoq cannot see those files although there in my folder.

I tried adding it in "Filter configurations" but it doesn't work, probably because there isn't an XLIFF filter therein.

How to do it?

Looking forward,
Collapse


 

Samuel Murray  Identity Verified
Նիդեռլանդներ
Local time: 07:49
Անդամ (2006)
անգլերենից աֆրիկանս
+ ...
@Zeki Jan 27, 2019

Zeki Güler wrote:
I received a project form my client in ".txlf" format and was told that to get the new files to work, I need to add "*.txlf;" to the beginning of the list of wildcard file extension types I have under "XLIFF" in my File Settings/Project Template.


1. Which version of MemoQ are you using?
2. Are you sure the client's instructions are for setting up a filter in MemoQ?

(I'm not a regular MemoQ user, but I have MemoQ installed and I tried some googling to get to the bottom of this, but I'm as baffled as you are. One can add a new XLIFF filter for TXLF files by clicking the "Resources" button at the very top left of MemoQ (the icon looks like a file-o-fax), and then selecting "Filter configurations" and then "Create New", but I'm stumped because there's nowhere where you can tell MemoQ to use the file extension ".txlf" for that filter.)


 

Andriy Yasharov  Identity Verified
Ուկրաինա
Local time: 08:49
Անդամ (2008)
անգլերենից ռուսերեն
+ ...
It works fine Jan 27, 2019

I have just checked and it works fine in memoQ 8.7.6.

The procedure is as follows:

New Project → Import with options → Select "All files" in the drop-down menu of the File Explorer → Select a txlf file to import → Click "Open" → Select XLIFF filter from the drop-down menu → Click OK → Click Finish.

The file gets imported with all the tags displayed properly.



[Edited at 2019-01-27 10:33 GMT]


Thomas T. Frost
 

Zeki Güler  Identity Verified
Թուրքիա
Local time: 09:49
Անդամ (2012)
անգլերենից թուրքերեն
+ ...
TOPIC STARTER
No txlf in drop down menu Jan 27, 2019

Thanks you guys,

Andriy,

I use 2014 R2 version.

But there is no txlf file available in the drop down menu. My Memoq doesn’t recognize this format and unable to see the txlf files for some reason.

Any further idea?


 

Andriy Yasharov  Identity Verified
Ուկրաինա
Local time: 08:49
Անդամ (2008)
անգլերենից ռուսերեն
+ ...
It must work no matter the version Jan 27, 2019

Zeki Güler wrote:
But there is no txlf file available in the drop down menu.


Of course there isn't. However, a txlf file is just an xliff file, the fact that can be proved by opening this kind of file with a text editor. You will see the following in the header: ?xml version="1.0" encoding="UTF-8"? xliff version="1.2" xmlns="urn:oasis:names:tc:xliff:document:1.2" xmlns:gs4tr="http://www.gs4tr.org/schema/xliff-ext"

So, use "Import with options", select "All files" in the drop-down menu of the file explorer (not "All supported files") so you can see all the files available in the file explorer window, select and open your txlf file and select XLIFF filter in the drop-down menu of the filters and click OK and then Finish.

Screenshot_11.jpg

[Edited at 2019-01-27 11:11 GMT]


Thomas T. Frost
Zeki Güler
 

Zeki Güler  Identity Verified
Թուրքիա
Local time: 09:49
Անդամ (2012)
անգլերենից թուրքերեն
+ ...
TOPIC STARTER
It works indeed Jan 27, 2019

Great! it works indeed Andriy

Many thanks for your help guys.

Cheers,


 

Lilian Brogna Staniscia  Identity Verified
Միացյալ Նահանգներ
Local time: 02:49
պորտուգալերենից անգլերեն
+ ...
Exporting Issues Jun 20

Does anyone else have issues when exporting txlf files with lots of tags? Usually files are not recognized by other CATs, like WF...

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

I can't import files in .txlf format

Advanced search






SDL Trados Studio 2021 Freelance
The leading translation software used by over 270,000 translators.

SDL Trados Studio 2021 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2021 transforms how new users get up and running and helps experienced users make the most of the powerful features.

More info »
SDL MultiTerm 2021
One central location to store and manage multilingual terminology.

By providing access to all those involved in applying terminology (such as engineers, marketers, translators, and terminologists), our terminology management solution ensures consistent and high-quality content from source through to translation.

More info »



Forums
  • All of ProZ.com
  • Բառերի որոնում
  • Պատվերներ
  • Ֆորումներ
  • Multiple search